Konica Minolta Bizhub 361 - Why A Scan To Email Won't Work - But Should

James Leone that_isridiculous at yahoo.com
Fri Aug 14 08:53:30 CST 2009


We recently had a mysterious problem in which we were unable to send scanned documents to outside email addresses with the settings we had in our Konica Minolta Bizhub 361.

When the Bizhub 361 would fail to send a scan via email - the only error message it would supply was: 

"SERVER CONNECTION ERROR"

I believed the setings were correct - but what I didn't know (and wouldn't have been able to find out unless I called AT&T webhosting) was:

1. Our ISP's SMTP service did not require authentication to send an email using their SMTP engine
2. The Bizhub would not send the scan if its told that SMTP authentication is required. Instead, it acts as if it has no communication with the Email server its trying to talk to - leaving the impression that the feature is broken or that a firewall prevents it from getting outside the network.

One reason why a Bizhub will fail to send a scan via email - in some circumstances - (with the only error indicated by the machine is stated as "SERVER CONNECTION ERROR") - is shown below.

Note that your email client may behave differently then a Bizhub - if you tell a Bizhub that SMTP authentication is required - and its not required - the Bizhub will only report back "SERVER CONNECTION ERROR." 

Some email clients won't tell you there was an initial problem, but instead, try to send the email without SMTP authentication - even if you provided a user name and password.

Quick solution 

First change the Bizhub's settings so that it thinks the SMTP engine its connecting to does not require outgoing SMTP authentication. If that fails, then try telling it that POP3 authentication is required before SMTP messages can be sent.

The two Bizhubs I worked with required 1 administrator email account and settings to be placed in the Bizhub's memory before it will send out emails.

I figured this out by using Wireshark to sort out what the issue was. 

I ran Wireshark on a successful transmission through an Internal Email server I set up in Open SuSE Linux 11.1. 

Ultimately I wanted to know why the Bizhub would not send its scans to an email account provided by our Internet Service Provider AT&T Webhosting.

Once I understood what the requirements were for sending our scans to email - I was able to can solve the problem by understanding its cause.

Wireshark is a network packet sniffer and analyzer. Assuming you know the IP number of the machine you are working on - you just have to run a capture in Wireshark - and then when you see a transmission that comes from your server - right click on it and select "Follow TCP stream"

When I did that in my situation, a sucessful transmission appeared as follows: 

220 hostname.OurDomainName.com ESMTP Postfix 

EHLO 192.168.0.1 

250-hostname.OurDomainName.com 
250-PIPELINING 
250-SIZE 10240000 
250-VRFY 
250-ETRN 
250-STARTTLS 
250-AUTH LOGIN PLAIN 
250-AUTH=LOGIN PLAIN 
250-ENHANCEDSTATUSCODES 
250-8BITMIME 
250 DSN 

AUTH LOGIN 

334 xxxxxxxxxxxx 

xxxxx= 

334 xxxxxxxxx 

xxxxxxxx= 

235 2.7.0 Authentication successful 

Now that I knew what a sucessful scan to email looked like - I set out to compare how our ISP's email account responded to the commands being sent to it by the Bizhub:

I connected to our company's outside email service provider's SMTP port with telnet - using the same IP number as our domain names' DNS registered IP number. I set out to replicate the Bizhubs commans I sniffed with Wireshark above. A guide on how to do this is provided in this link:

http://www.wikihow.com/Send-Email-Using-Telnet

Here is what happened: 

telnet xxx.xxx.xxx.xxx 25 

Trying xxx.xxx.xxx.xxx... 

Connected to xxx.xxx.xxx.xxx. 

Escape character is '^]'. 

220 OurDomainName.com 

ESMTP 

EHLO OURDOMAINNAME.COM 

250-ourdomainname.com 

250-PIPELINING 

250-SIZE 10485760 

250 8BITMIME 

AUTH LOGIN 

502 unimplemented (#5.5.1) 

(At this point the Bizhub with only report: "SERVER CONNECTION ERROR" 
which is patently misleading in our case.)

********************************************** 

The 502 unimplimented means that you can't log in to access the SMTP services provided at this port.

I wanted to know if our ISP allowed this - or if it was a situation in which POP3 had to be authenticated first - then SMTP would be accessable. So, I tested to see if I could send an email without authentication: 

MAIL FROM: James at OurDomainName.com 

250 OK 

RCPT TO; John at OurDomainName.com 

DATA 

354 go ahead 

SUBJECT: This is a test 
. 
************************************************** ***** 
Email arrived at its intended destimation without a problem. SMTP authentication was not required.

When I changed the SMTP settings in the Bizhub to indicate that SMTP authentication was not required - it worked without a hitch.



      



More information about the linuxsa mailing list