Alsamixer

Andrew Lord andrewlord at internode.on.net
Wed May 21 16:36:31 CST 2003


Hi all,

Got a bit of a problem getting alsamixer to run.  

Initially, I could get alsamixer to run, simply by typing its name at the 
prompt.   Now, it doesn't.

In between times, I have managed to get my sound card (Vibra128) to work on my 
Mandrake 9.1 system (Alsamixer and all other packages weren't a lot of use 
without this, I'm affraid), by selecting the appropriate driver through the 
Mandrake Control Centre (the default driver that installed didn't work for 
some reason).  Excellent.  Problem is that this is what seems to have broken 
Alsamixer.  Aumix works fine but unfortunately, I need alsamixer in order to 
attempt some multitrack recording and to work in conjunction with some other 
programs.

Typing alsamixer at the prompt, I get:
	"alsamixer: function snd_ctl_open failed for default: No such file or 
directory"

Typing lsmod, the soundcard driver is identified as es1371.

Module                  Size  Used by    Not tainted 
ppp_deflate             4408   0  (autoclean) 
zlib_deflate           21144   0  (autoclean) [ppp_deflate] 
bsd_comp                5336   0  (autoclean) 
msdos                   7404   0  (autoclean) 
isofs                  27988   0  (autoclean) 
zlib_inflate           21156   0  (autoclean) [ppp_deflate isofs] 
udf                    90464   0  (autoclean) 
ide-floppy             15580   0  (autoclean) 
sd_mod                 13100   0  (autoclean) (unused) 
autofs4                11540   2  (autoclean) 
lp                      8096   0  
parport_pc             25096   1  
parport                34176   1  [lp parport_pc] 
es1371                 29000   1  
soundcore               6276   0  [es1371] 
ac97_codec             12488   0  [es1371] 
gameport                3316   0  [es1371] 
nfsd                   74256   8  (autoclean) 
ppp_async               9216   0  
ppp_generic            24060   0  [ppp_deflate bsd_comp ppp_async] 
slhc                    6564   0  [ppp_generic] 
af_packet              14952   0  (autoclean) 
ip_vs                  83192   0  (autoclean) 
sr_mod                 16920   0  (autoclean) 
floppy                 55132   0  
sis900                 15564   1  (autoclean) 
nls_iso8859-1           3516   1  (autoclean) 
nls_cp850               4316   1  (autoclean) 
vfat                   11820   1  (autoclean) 
fat                    37944   0  (autoclean) [msdos vfat] 
supermount             15296   2  (autoclean) 
ide-cd                 33856   2  
cdrom                  31648   0  [sr_mod ide-cd] 
ide-scsi               11280   0  
scsi_mod              103284   3  [sd_mod sr_mod ide-scsi] 
printer                 8448   0  
usb-ohci               20584   0  (unused) 
usbcore                72992   1  [printer usb-ohci] 
rtc                     8060   0  (autoclean) 

My /etc/modules.conf file looks like this:

alias net-pf-4 ipx
alias autofs autofs4
probeall scsi_hostadapter ide-scsi
alias sound-slot-1 es1371
alias eth0 sis900
above snd-trident snd-pcm-oss
alias sound-slot-0 es1371
probeall usb-interface usb-ohci
above snd-ens1371 snd-pcm-oss

I have tried pointing alsamixer to the sound card location (1 ???).  Not sure 
if I've tried this appropriately though, anyway when I type "alsamixer -c 1" 
at the command line (to select the sound card to use), I get:
	"alsamixer: function snd_ctl_open failed for hw:1: No such file or directory"

I'm guessing that the driver that alsamixer points to needs to be updated, but 
have no idea of what file would need to be changed.  Is this a correct guess, 
and has anybody had/overcome this difficulty please ? 

Also when I type arecord -l (to list the available sound cards, I get):
	"arecord: device_list:190: no soundcards found..."

Any help would be appreciated.

Cheers,

Andrew Lord


-- 
LinuxSA WWW: http://www.linuxsa.org.au/ IRC: #linuxsa on irc.freenode.net
To unsubscribe from the LinuxSA list:
  mail linuxsa-request at linuxsa.org.au with "unsubscribe" as the subject



More information about the linuxsa mailing list