umount problem

David Ananian-Cooper davidac17 at yahoo.com
Sat May 17 22:44:00 CST 2003


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Sat, 17 May 2003 21:38, Brian Marr wrote:
> Are you mounting these shares and someone at the other end turns the PC off
> ?

yep, thats pretty much what happened - the proceedure i describe above was a
description of how i managed to replicate the situation - not what happened.
what i think happened was that the guy switched off his machine, and then i
thought that killing the mount.smbfs process would kill the mount (as umount
wasnt working) - but it only made it worse.

as far as i'm concerned - if theres no way to kill the mount, then theres
something seriously wrong as this is a situation which i think would be
reasonably common!!!!

> A clean unmount is cause for concern. They can be a real pain. You could
> try restarting smb and nmb. When I need to kill a process I normally do a
> ps -aux and look for the problem. Also ps -aux | grep smb could help.

i've tried that. i've also tried logging out of every terminal, shutting down
all network services etc and nothing seems to make any difference. i dont
want to resort to rebooting as this is linux - i shouldnt have to reboot to
rectify such a simple thing, thats what i would have to do in windows!!!
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.1 (GNU/Linux)

iD8DBQE+xj4RqKJjsK82VBsRAimMAJ98fuY3UrvZmKOiNNgACgMgZ6LHDwCeI11D
SwEr7pBB0J7gDYhDAYkBklY=
=s2CS
-----END PGP SIGNATURE-----

-- 
LinuxSA WWW: http://www.linuxsa.org.au/ IRC: #linuxsa on irc.freenode.net
To unsubscribe from the LinuxSA list:
  mail linuxsa-request at linuxsa.org.au with "unsubscribe" as the subject



More information about the linuxsa mailing list